Primer arranque de XBian y configuración básica

Hoy por fin he encontrado un poco de tiempo para continuar donde lo dejamos, con nuestra tarjeta SD recién copiada y lista para ser insertada en la Raspberry Pi, así que a ello vamos.

Raspberry junto a la tarjeta SD y el dongle WiFiAquí podéis ver prácticamente lo único que necesitaremos para hacer funcionar nuestra Raspi como el gran gestor multimedia que esperamos que sea. El pequeño cacharrito que hay a a la izquierda es un adaptador WiFi N de la marca TP-Link que compré en Amazon por poco más de 8 € (enlace). Elegí este modelo porque en los foros de Raspberry estaba sobradamente comprobado que funcionaba correctamente sin utilizar un hub autoalimentado. Si estáis pensando en compraros un adaptador WiFi, os recomendaría que primero pasarais por allí para comprobar que es compatible, no sea que luego os llevéis un chasco.

Adaptador de corriente de una blackberryEste es (aparte del cable HDMI) el otro componente que necesitareis para darle vida a nuestra Raspi: un adaptador de corriente con toma micro usb. Esta toma es la que llevan por ejemplo las Blackberries (de donde proviene este en particular) y los Kindle de Amazon, amén de muchos otros dispositivos. Lo único que tenéis que tener en cuenta es que la potencia de salida sea de al menos 700mA, aunque se recomienda que tenga 1A. Este mío es de 700mA y de momento no me ha dado errores. Pues nada, no me enrollo, le voy vida y arrancamos.

XBian está terminando de isntalarEsta es la pantalla que veréis durante el primer arranque de XBian, mientras termina de configurar algunas cosas. Al menos la barra de progreso nos va indicando cuanto falta.

Welcome to XBianDespués de unos momentos nos aparecerá la siguiente ventana que nos indica que el sistema ha sido correctamente instalado. Además nos dice dónde debemos ir para hacer la configuración inicial de nuestra instalación.

Controlando XBMC con el mando de la teleUna de las cosas que me gusta de utilizar XBMC en la Raspberry, es que hace uso de las posibilidades bidireccionales del cable HDMI, por lo que puedo manejarlo directamente con el mando de mi televisor.

Pantalla de inicioY aquí está, la pantalla de inicio de XBMC listo para usar. Bueno… casi. Aún faltan algunos pequeños ajustes iniciales, así que a ello vamos.

System - SettingsMe voy a System – Settings para acceder a la configuración.

Configuración regionalEn la sección de Apariencia, Ajustes podemos cambiar el idioma a Español, la región a España y 12h o 24h, y el país y la zona para que coja la hora correcta. Además se puede modificar el idioma por defecto para el audio y los subtítulos, aunque esto no lo voy a cambiar (al menos de momento).

No ignorar los artículosA mi no me gusta que a la hora de ordenar las películas ignore los artículos. Es decir, me gusta que “El Hobbit” aparezca en la letra E y no en la letra H. Por suerte eso se puede cambiar fácilmente con esta opción.

Actualizar la colección en el arranqueTambién quiero que la biblioteca se actualice automáticamente en el arranque, por lo que marco también esa opción.

Control de XBMC por HTTPSi más adelante querréis manejar XBMC desde vuestro navegador o desde una aplicación para smartphone, esta es la opción que tenéis que habilitar para tal fin.

Habilitar AirplayTambién quiero que XBMC sea capaz de recibir cualquier cosa que los iPhone le manden por Airplay, así que habilito la opción pertinente.

Permitir log mediante SSHMe gusta manejar mi Raspi mediante la consola del iMac (y del iPhone) utilizando SSH, así que también habilito esta opción. Más adelante os enseñaré cómo hacer para que al hacer loggeo por SSH desde un dispositivo conocido no nos pida contraseña.

Conexion a la redUna cosa espectacular que tiene XBian es la facilidad para la conexión WiFi. Como ya tengo el dongle enchufado, aquí le dicho que la interfaz de red es la wlan0, le pongo el modo de opción de IP en DHCP (importante) y luego busco el nombre del SSID de mi router. No os podéis imaginar cómo simplifica esto el proceso de conectarse a una WiFi (gracias XBian).

El tiempo en AlcobendasPara probar que la conexión a internet está funcionando correctamente, nada tan fácil como abrir la aplicación del tiempo que viene por defecto en XBMC. Seleccionamos el municipio en el que nos encontramos (u otro cualquiera de nuestra elección) y, si nos da algo como esto, es que está funcionando.

Eso es todo de momento. Por ahora tenemos XBian instalado como sistema operativo en nuestra tarjeta SD y además lo tenemos conectado a la red. En la siguiente entrada os diré como conectarnos desde nuestro equipo a la Raspberry para otra continuar con las instalaciones y configuraciones.

Anuncios

14 comentarios en “Primer arranque de XBian y configuración básica

  1. Hola,
    Hace poco me regalaron una raspberry pi a la que se instaló xbian, todo funciona bien excepto el wifi. Tengo el mismo adaptador que tu, selecciono wlan0 en la configuración network con modo DHCP y en Ssid no me aparece nada, al seleccionarlo me dice que está escaneando buscando wlan, en este momento se pone a parpadear la luz azul del adaptador, me sale un desplegable para seleccionar la red pero sin ninguna opción, deja de parpadear la luz azul y cuando lo cierro me pone un aviso abajo a la derecha que no se puede conectar wlan0. ¿No sabrás a qué es debido ésto?
    Muchas gracias y un saludo,
    Manolo

    • Hola Manolo.
      Lo primero perdona por haber tardado tanto en contestar.
      La verdad es que no recuerdo si me dio algún problema la configuración de la WiFi, creo que no.
      ¿Te llega a detectar alguna red de algún vecino? si no tienes ningún vecino cerca con WiFi puedes intentar crear tú una con tu smartphone si lo tienes, o incluso con tu ordenador.
      Otra prueba que te aconsejo hacer es conectar el dongle a un ordenador, deshabilitar todos los otros dispositivos de red que tengas (WiFi y Ethernet) e intentar conectarte a internet. No sería la primera vez que me doy de cabezazos intentando hacer funciona algo que resulta que está defectuoso.
      Dime cómo evoluciona la cosa ¿ok? un saludo

      • Gracias por la respuesta Torrated.
        Creo que ya sé porqué no me funciona el wifi. He leído por ahí que TP-Link cambió el chip del WN725N a finales de 2013 sin cambiar la numeración ni avisar del cambio del chip y por lo visto no es compatible, al menos hasta hace un mes, con xbian. Al final opté por instalar el Raspbian que sí era compatible.
        Un saludo.

    • Hola Pablo. Pues sí que me pasaba mucho con XBian que le costaba mucho coger señal de nuevo. A veces era cuestión de esperar varios minutos y otras, de darle otro reinicio. Ahora que tengo RaspBMC no me pasa.
      Una forma de evitarte ese problema sería forzar la configuración de tu red editando el fichero /etc/network/interfaces

  2. Gracias, por tu respuestas,
    Otra cosa que me ha pasado es que en primer reinicio también se quedaba pillada en resize fs, o al conectar el pincho USB re reinicia. entonces me recomiendas raspbmc?

    • Lo de que se reinicie al enchufar un USB puede llegar a ser normal en la Raspberry modelo A o B (no en el B+) ya que al no tener la suficiente potencia el USB, a veces da ese problema.
      En cuanto al problema del resize nunca me ha pasado, así que no sé decirte.

    • Creo recordar que también me dio algunos problemas al principio porque, aunque veía las redes, no conseguía conectarme. Luego al final acabó conectando y no he vuelto a tener problemas. ¿Has probado a añadir la configuración de tu red en /etc/network/interfaces ?

  3. Buenas noches, al final he seguido tu tutorial al pie de la letra y conseguí que funcionase, las primeras 24 horas. Luego he intentado trastear ssh y me cargue el sistema. Tras formatear la tarjeta sd, volví a usar el instalador de raspbmc y cual es mi sorpresa que aunque lo he intentado con 2 tarjetas, mi raspberry no arranca. Se queda solo con la luz roja de power encendida. Te ha pasado a ti alguna vez?

  4. Tuve problemas con una de mis microsd que usaba junto a un adaptador para SD pero nada que un formateo no pudiera solucionar.
    En tu caso, mucha casualidad sería que ambas tarjetas SD estuvieran mal. Para descartar un fallo de la Raspberry yo probaría lo siguiente:
    – instalar otra distribución
    – cambiar los cables (video y alimentación)
    – ¿Se llega a encender el piloto verde parpadean?
    Espero que lo puedas solucionar.

  5. Hola, se que hace ya tiempo de estos post, pero he encontrado una mención al problema que tengo con mi raspberry pi, primera edicion, creo que modelo B. El caso que es que tenía instalado Xbian pero se me quedo congelado. He intentado re-instalarlo, pero no consigo que una vez seguidos los pasos que enumeras arriba, se me queda el piloto de la raspberry pi en rojo y no reconoce nada en la tarjeta SD. No lo entiendo. He instalado OSMC y funciona perfectamente. No se que le pasa. Espero que tengas alguna solución al respecto. Un saludo.

  6. Hola Gomarizo. Así de primeras no sabría decirte qué podría estar fallando ya que como tú muy bien dices estas instrucciones eran válidas hace ahora dos años pero no estoy seguro de que lo sigan siendo. Como tengo mi raspberry modelo B para pruebas, voy a escribir un nuevo post sobre esta primera instalación y configuración para comprobar si sigue siendo válido y (quizás) solucionar tu problema. Estate atento los próximos días. Saludos.

  7. Pingback: Instalando y configurando XBian | Torrated

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s